思科路由器禁止下载和限速

路由器设置 2018-04-24 1553 0 1830字
- N +

今天,www.xiqb.com将通过对思科路由器的发展背景,了解路由器在使用中如何进行限速的操作,同时对于限速问题,实现对BT流量的控制,以及实现对PDLM的支持问题作出你详细解答。

falogin.cn更改密码,tplink初始密码,192 168 1 1,192.168.1.253,怎么修改路由器密码,网件无线路由器

思科路由器禁止下载和限速的知识

  一、当前路由器形势

大家都知道如果要限制某项服务,就要在路由器上设置ACL(访问控制列表)将该服务所用的端口封掉,从而阻止该服务的正常运行。对BT软件,我们可以尝试封它的端口。一般情况下,BT软件使用的是6880-6890端口,在公司的核心思科路由器上使用以下命令将6880-6890端口全部封锁。

  二、路由器限速

access-list 130 remark bt

access-list 130 permit tcp any any range 6881 6890

access-list 130 permit tcp any range 6881 6890 any

rate-limit input access-group 130 712000 8000 8000 conform-action transmit exceed-action drop

rate-limit output access-group 130 712000 8000 8000 conform-action transmit exceed-action drop

  三、路由器禁止下载

access-list 130 deny tcp any any range 6881 6890

access-list 130 deny tcp any range 6881 6890 any

ip access-group 130 in / out

现在的bt软件,再封锁后会自动改端口,一些软件还是用到8000、8080、2070等端口,限制这些端口这样网络会不正常。

  四、使用NVAR(Network-Based Application Recognition,网络应用识别)

NBAR (Network-Based Application Recognition) 的意思是网络应用识别。NBAR 是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL 能做到那样控制静态的、简单的网络应用协议TCP/UDP 的端口号。例如我们熟知的WEB 应用使用的TCP 80 ,也能做到控制一般ACLs 不能做到动态的端口的那些协议,例如VoIP 使用的H.323,SIP 等。

要实现对BT 流量的控制,就要在思科路由器上实现对PDLM 的支持。PDLM 是Packet Description Language Module 的所写,意思是数据包描述语言模块。它是一种对网络高层应用的协议层的描述,例如协议类型,服务端口号等。它的优势是让NBAR 适应很多已有的网络应用,像HTTP URL ,DNS ,FTP,VoIP 等, 同时它还可以通过定义,来使NBAR 支持许多新兴的网络应用。例如peer2peer 工具。PDLM 在思科的网站上可以下载,并且利用PDLM 可以限制一些网络上的恶意流量。CISCO在其官方网站提供了三个PDLM模块,分别为KAZAA2.pdlm,bittorrent.pdlm.emonkey.pdlm可以用来封锁KAZAA,BT,电驴得到PDLM然后通过TFTP服务器将bittorrent.pdlm 拷贝到路由中。利用ip nbar pdlm bittorrent.pdlm命令将NBAR中的BT 功能启动。再创建一个class-map 和policy map 并且把它应用到相应的思科路由器的接口上。一般是连接Internet (Chinanet ) 的接口是FastEthernet 或10M 的以太网接口。在思科路由器上您可以看见如下的配置:

class-map match-all bittorrent

match protocol bittorrent

!

!

policy-map bittorrent-policy

class bittorrent

drop

!

interface FastEthernet0/

description neibujiekou

ip address 192.168.0.1 255.255.255.0

ip nat inside

service-policy input bittorrent-policy

service-policy output bittorrent-policy

!

如此这般,就可以在你的公司或单位的因特网接入思科路由器上实施一些流量控制,同时NBAR和PDLM还可以应用在您公司和单位的内联广域网上,可以保证广域网带宽的合理使用,是不是很方便呢!
 

分享到您的社交平台:

发表评论:

您必须 [ 登录 ] 才能发表留言!