思科路由器配置命令-Cisco路由器配置入门知识(基础)

路由器限速 2016-08-21 945 0 25510字
- N +

Cisco路由器常用命令汇总

下面就由电脑知识吧的小编为大家带来一批:“Cisco 路由器常用命令汇总”,希望可以帮助到大家:

1 Exec commands:

<1-99>; 恢复一个会话

bfe 手工应急模式设置

clear 复位功能

clock 管理系统时钟

configure 进入设置模式

connect 打开一个终端

copy 从tftp服务器拷贝设置文件或把设置文件拷贝到tftp服务器上

debug 调试功能

disable 退出优先命令状态

disconnect 断开一个网络连接

enable 进入优先命令状态

erase 擦除快闪内存

exit 退出exce模式

help 交互帮助系统的描述

lat 打开一个本地传输连接

lock 锁定终端

login 以一个用户名登录

logout 退出终端

mbranch 向树形下端分支跟踪多路由广播

mrbranch 向树形上端分支跟踪反向多路由广播

name-connection 给一个存在的网络连接命名

no 关闭调试功能

pad 打开X.29 PAD连接

ping 发送回显信息

ppp 开始点到点的连接协议

reload 停机并执行冷启动

resume 恢复一个活动的网络连接

rlogin 打开远程注册连接

rsh 执行一个远端命令

send 发送信息到另外的终端行

setup 运行setup命令

show 显示正在运行系统信息

slip 开始SLIP协议

start-chat 在命令行上执行对话描述

systat 显示终端行的信息

telnet 远程登录

terminal 终端行参数

test 测试子系统内存和端口

tn3270 打开一个tin3270连接

trace 跟踪路由到目的地

undebug 退出调试功能

verify 验证检查闪烁文件的总数

where 显示活动的连接

which-route 执行OSI路由表查找并显示结果

write 把正在运行的设置写入内存、网络、或终端

x3 在PAD上设置X.3参数

xremote 进入xremote模式

活着就意味着必须要做点什么,请好好努力

我的名称:电脑知识吧

我的账号:dnzsb_com(←长按复制)

电脑知识吧 http://www.dnzsb.com/article-5750-1.html


【VIDOAM资讯快车】Cisco路由器安全配置命令。

【微信号:vidomaIT】vidoma IT每天精选IT网络系统行业最新学习就业动态,以及深度有趣文章与资讯,绝对适合为求更好职业发展的你。更多精彩请点击标题下方↑↑↑↑vidomaIT点击关注哦。

[维多玛网络教育:YY89579588] 记得关注时刻提升自己哦

Cisco路由器安全配置命令

有哪个命令的标准是你希望思科在每台路由器上都使用的吗?每位管理员都其自己的“正确”配置每台路由器的命令。本文的十条命令是我认为你应该在每台路由器上都配置的,没有特别的顺序。

1、在路由器上配置一个登录帐户

我强烈建议在路由器和交换机上配置一个真实的用户名和口令帐号。这样做,意味着你需要用户和口令来获得访问权。

除此之外,我建议为用户名使用一个秘密口令,而不仅有一个常规口令。它用MD5加密方法来加密口令,并且大大提高了安全性。举例如下:

Router(config)#username root secret My$Password

在配置了用户名后,你必须启用使用该用户名的端口。举例如下:

Router(config)#line con 0

Router(config-line)#loginlocal

Router(config)#lineaux 0

Router(config-line)#loginlocal

Router(config)#linevty 0 4

Router(config-line)#loginlocal

2、在路由器上设置一个主机名

我猜测路由器上缺省的主机名是router。你可以保留这个缺省值,路由器同样可以正常运行。然而,对路由器重新命名并唯一地标识它才有意义。举例如下:

Router(config)#hostnameRouter-Branch-23

除此之外,你可以在路由器上配置一个域名,这样它就知道所处哪个DNS域中。举例如下:

Router-Branch-23(config)#ipdomain name TechRepublic.com

3、为进入特权模式设置口令

当谈到设置进入特权模式的口令时,许多人想到使用enablepassword命令。然而,代替使用这个命令,我强烈推荐使用enablesecret命令。

这个命令用MD5加密方法加密口令,所以提示符不以明文显示。举例如下:

Router(config)#enablesecret My$Password

4、加密路由器口令

Cisco路由器缺省情况下在配置中不加密口令。然而,你可以很容易地改变这一点。举例如下:

Router(config)#servicepassword-encryption

5、禁用Web服务

Cisco路由器还在缺省情况下启用了Web服务,它是一个安全风险。如果你不打算使用它,最好将它关闭。举例如下:

Router(config)#noip http server

6、配置DNS,或禁用DNS查找

让我们讨论Cisco路由器中我个人认为的一个小毛病:缺省情况下,如果在特权模式下误输入了一个命令,路由器认为你试图Telnet到一个远程主机。然而它对你输入的内容却执行DNS查找。

如果你没有在路由器上配置DNS,命令提示符将挂起直到DNS查找失败。由于这个原因,我建议使用下面两个方法中的一个。

一个选择是禁用DNS。做法是:

Router(config)#noip domain-lookup

或者,你可以正确地配置DNS指向一台真实的DNS服务器。

Router(config)#ipname-server

7、配置命令别名

许多网络管理员都知道在路由器上配置命令的缩写(也就是别名)。举例如下:

Router(config)#aliasexec s sh run

这就是说你现在可以输入s,而不必输入完整的showrunning-configuration命令。

8、设置路由器时钟,或配置NTP服务器

多数Cisco设备没有内部时钟。当它们启动时,它们不知道时间是多少。即使你设置时间,如果你将路由器关闭或重启,它不会保留该信息。

首先设置你的时区和夏令时。例子如下:

Router(config)#clocktimezone CST-6

Router(config)#clocksummer-time CDT recurring

然后,为了确保路由器的事件消息显示正确的时间,设置路由器的时钟,或者配置一个NTP服务器。设置时钟的例子如下:

Router# clock set10:54:00 Oct 5 2005

如果你已经在网络中有了一个NTP服务器(或可以访问Internet的路由器),你可以命令路由器将之作为时间源。这是你最好的选择,当路由器启动时,它将通过NTP服务器设置时钟。举例如下:

Router(config)# ntpserver 132.163.4.101

9、不让日志消息打扰你的配置过程

CiscoIOS中另一个我认为的小毛病就是在我配置路由器时,控制台界面就不断弹出日志消息(可能是控制台端口,AUX端口或VTY端口)。要预防这一点,你可以这样做。

所以在每一条端口线路上,我使用日志同步命令。举例如下:

Router(config)#linecon 0

Router(config-line)#loggingsynchronous

Router(config)#lineaux 0

Router(config-line)#loggingsynchronous

Router(config)#linevty 0 4

Router(config-line)#loggingsynchronous

除此之外,你可以在端口上修改这些端口的执行超时时间。例如,我们假设你想禁用VTY线路上默认的十分钟超时时间。在线路配置模式下使用exec-timeout00命令,使路由器永不退出。

10、在路由器缓冲区或系统日志服务器中记录系统消息

捕获路由器的错误和事件以及监视控制台是解决问题的关键。默认情况下,路由器不会将缓冲的事件记录发送到路由器内存中。

然而,你可以配置路由器将缓冲的事件记录发送到内存。举例如下:

Router(config)#loggingbuffered 16384

你还可以将路由器事件发送到一个系统日志服务器。由于该服务器处在路由器外部,就有一个附加的优点:即使路由器断电也会保留事件记录。

选择维多玛的理由:

专家级讲师团队:大连地区最专业的讲师团队

高端的实验基地:东北地区设备使用率最高

小班贴身式授课:东北的确认证通过率最高

企业级案例分析:大连地区就业率最高

贴心的售后服务:东北地区口碑最好

培训+考试一站式服务:大连地区唯一VUE考试中心。


思科路由器常用CCNA命令解释

在一些高端路由器的设置过程中,经常会用到各种的命令,这也是每一个网管必备的常识,本文就介绍一个常用的命令:CCNA,有不少人知道这些吧,不过还有你不知道的一面。

由于命令太多,我们就以字母来进行排序。

一、A部分:

1、Access-enable 允许路由器在动态访问列表中创建临时访问列表入口;

2、Access-group 把访问控制列表(ACL)应用到接口上;

3、Access-list 定义一个标准的IP ACL;

4、Access-template 在连接的路由器上手动替换临时访问列表入口;

5、Appn 向APPN 子系统发送命令;

6、Atmsig 执行ATM 信令命令。

二、B部分:

1、Bandwidth 设置接口的带宽;

2、Banner motd 指定日期信息标语;

3、Bfe 设置突发事件手册模式;

4、Boot system 指定路由器启动时加载的系统映像。

三 C部分

1、Calendar 设置硬件日历;

2、Cd 更改路径;

3、Cdp enable 允许接口运行CDP 协议;

4、Clear 复位功能;

5、Clear counters 清除接口计数器;

6、Clear interface 重新启动接口上的硬件逻辑;

7、Clockrate 设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率;

8、Cmt 开启/关闭FDDI 连接管理功能;

9、Config-register 修改配置寄存器设置;

10、Configure 允许进入存在的配置模式,在中心站点上维护并保存配置信息;

11、Configure memory 从NVRAM 加载配置信息;

12、Configure terminal 从终端进行手动配置;

13、Connect 打开一个终端连接;

14、Copy 复制配置或映像数据;

15、Copy flash tftp 备份系统映像文件到TFTP 服务器;

16、Copy running-config startup-config 将RAM 中的当前配置存储到NVRAM;

17、Copy running-config tftp 将RAM 中的当前配置存储到网络TFTP 服务器上;

18、Copy tftp flash 从TFTP 服务器上下载新映像到Flash;

19、Copy tftp running-config 从TFTP 服务器上下载配置文件。

四、D部分:

1、Debug 使用调试功能;

2、Debug dialer 显示接口在拨什么号及诸如此类的信息;

3、Debug ip rip 显示RIP 路由选择更新数据;

4、Debug ipx routing activity 显示关于路由选择协议(RIP)更新数据包的信息;

5、Debug ipx sap 显示关于SAP(业务通告协议)更新数据包信息;

6、Debug isdn q921 显示在路由器D 通道ISDN 接口上发生的数据链路层(第2 层)的访问过程;

7、Debug ppp 显示在实施PPP 中发生的业务和交换信息;

8、Delete 删除文件;

9、Deny 为一个已命名的IP ACL 设置条件;

10、Dialer idle-timeout规定线路断开前的空闲时间的长度;

11、Dialer map 设置一个串行接口来呼叫一个或多个地点;

12、Dialer wait-for-carrier-time 规定花多长时间等待一个载体;

13、Dialer-group 通过对属于一个特定拨号组的接口进行配置来访问控制;

14、Dialer-list protocol 定义一个数字数据接受器(DDR)拨号表以通过协议或ACL 与协议的组合来控制控制拨号;

15、Dir 显示给定设备上的文件;

16、Disable 关闭特许模式;

17、Disconnect 断开已建立的连接。

五、E部分:

1、Enable 打开特许模式;

2、Enable password 确定一个密码以防止对路由器非授权的访问;

3、Enable password 设置本地口令控制不同特权级别的访问;

4、Enable secret 为enable password 命令定义额外一层安全性;

5、Encapsulation frame-relay 启动帧中继封装;

6、Encapsulation novell-ether 规定在网络段上使用的Novell 独一无二的格式;

7、Encapsulation PPP 把PPP 设置为由串口或ISDN 接口使用的封装方法;

8、Encapsulation sap 规定在网络段上使用的以太网802.2 格式Cisco 的密码是sap;

9、End 退出配置模式;

10、Erase 删除闪存或配置缓存;

11、Erase startup-config 删除NVRAM 中的内容;

12、Exec-timeout 配置EXEC 命令解释器在检测到用户输入前所等待的时间;

13、Exit 退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC;

14、Exit 终止任何配置模式或关闭一个活动的对话和结束EXEC.

关于思科路由器CCNA的命令就给大家介绍到这里了,相信通过上面介绍大家已经全面了解了该命令的作用,其他路由器上也是一样的。


思科交换机配置命令-交换机显示命令

用户在登陆到设备的超级用户模式下,使用show命令可以查看设备相关信息,可以通过“show ?”来查询可以使用哪些命令。

switch#write

;保存配置信息

switch#show vtp status

;查看vtp配置信息

switch#show running-config

;查看当前配置信息

switch#show vlan

;查看vlan配置信息

switch#show interfaces

;查看端口信息

switch#show interfaces fastEthernet 0/1

;查看指定端口信息


CISCO路由的基本设置方式和命令状态

一、基本设置方式

一般来说,可以用5 种方式来设置路由器:

1.Console 口接终端或运行终端仿真软件的微机;

2.AUX 口接MODEM,通过电话线与远方的终端或运行终端仿真软件的微机相连;

3.通过Ethernet 上的TFTP 服务器;

4.通过Ethernet 上的TELNET 程序;

5.通过Ethernet 上的SNMP 网管工作站。

但路由器的第一次设置必须通过第一种方式进行,此时终端的硬件设置如下:

波特率:9600

数据位:8

停止位:1

奇偶校验: 无

二、命令状态

1. router>

路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容。

2. router#

在router>提示符下键入enable,路由器进入特权命令状态router#,这时不但可以执行所有的用户命令,还可以看到和更改路由器的设置内容。

3. router(config)#

在router#提示符下键入configure terminal,出现提示符router(config)#,此时路由器处于全局设置状态,这时可以设置路由器的全局参数。

4. router(config-if)#; router(config-line)#; router(config-router)#;...

路由器处于局部设置状态,这时可以设置路由器某个局部的参数。

5. >

路由器处于RXBOOT 状态,在开机后60 秒内按ctrl-break 可进入此状态,这时路由器不能完成正常的功能,只能进行软件升级和手工引导。

设置对话状态

这是一台新路由器开机时自动进入的状态,在特权命令状态使用SETUP 命令也可进入此状态,这时可通过对话方式对路由器进行设置。


详解Cisco路由的过滤命令

(一) Route Maps

特性:

Route Maps类似于Access lists,不同之处在于Route Maps可以改变Packets/Routes的部分属性。

用途:

Route Maps主要用于Redistribution和Policy Routing及BGP的实现。

实现:

Policy Routing发送Packets到Route Maps实现策略路由转发。

Redistribution发送Routes到Route Maps实现路由条目的过滤。

配置说明:

Route Maps假如没有指定Action及Sequence Number属性,默认:

Action: permit

Sequence Number: 10

且Sequence Number不会自动增加。

即假如在使用Route Maps语句时不指定Sequence Number,则覆盖Sequence Number为10的默认条目。

Route Maps Deny Action:

Redistribution: 特定路由条目不会被重分布。

Policy Routing: 特定的Packets不会按策略路由转发,但会梗概正常的路由表条目转发。

Case Study:Policy Routing

注:(1)Policy Routing只影响入流量。

(2)可以使用Standard及Extended ACL.

(3)全局配置ip local policy route-map sense可将策略路由应用于Router本身发送的Packets.

<1> Standard ACL

interface Serial 0

ip address 172.16.5.1 255.255.255.0

ip policy route-map sense

!

access-list 1 permit 172.16.6.0 0.0.0.255

access-list 2 permit 172.16.7.0 0.0.0.255

!

route-map sense permit 10

match ip address 1

set ip next-hop 172.16.4.2

!

route-map sense permit 20

match ip address 2

set ip next-hop 172.16.4.3

<2> Extended ACL

interface Ethernet 0

ip address 172.16.1.4 255.255.255.0

ip policy route-map sense

!

access-list 105 permit tcp 172.16.1.0 0.0.0.255 eq FTP any

access-list 105 permit tcp 172.16.1.0 0.0.0.255 eq ftp-data any

access-list 106 permit tcp 172.16.1.0 0.0.0.255 eq telnet any

!

route-map sense permit 10

match ip address 105

set ip next-hop 172.16.2.1

!

route-map sense permit 20

match ip address 106

set ip next-hop 172.16.3.1

<3> Length of the Packets

interface Ethernet0

ip address 172.16.1.4 255.255.255.0

ip policy route-map sense

!

route-map sense permit 10

match length 1000 1600

set ip next-hop 172.16.2.1

!

route-map sense permit 20

match length 0 400

set ip next-hop 172.16.3.1

<4> Router's Packets

interface Ethernet0

ip address 172.16.1.4 255.255.255.0

ip policy route-map sense

!

ip local policy route-map sense

!

access-list 120 permit ip any 172.16.1.0 0.0.0.255

access-list 120 permit ospf any any

!

route-map sense permit 10

match ip address 120

!

route-map sense permit 20

match length 1000 1600

set ip next-hop 172.16.2.1

!

route-map sense permit 30

match length 0 400

set ip next-hop 172.16.3.1

注:假如没有第一个route-map条目,router本身的Packets及OSPF的Packets都会由于后两个route-map语句被转发到错误的地址。

Case Study: Policy Routing and Quality of Service Routing

Policy Routing结合ip包头的Precedence和Type of Service(TOS)可以实现基于QOS的策略路由。

注:Precedence和TOS的配置既可使用Number字段,也可以使用KeyWord.

set ip precedence

-------------------------------------

Bits Number Keyword

000 0 routine

001 1 priority

010 2 immediate

011 3 flash

100 4 flash-override

101 5 critical

110 6 internet

111 7 network

-------------------------------------

set ip tos

-------------------------------------

Bits Number Keyword

0000 0 normal

0001 1 min-monetary-cost

0010 2 max-reliability

0100 4 max-throughput

1000 8 min-delay

-------------------------------------

interface Serial0

ip address 10.1.18.67 255.255.255.252

ip policy route-map sense

!

interface Serial1

ip address 10.34.16.83.255.255.255.252

ip policy route-map sense

!

access-list 1 permit 172.16.0.0 0.0.255.255

access-list 110 permit tcp any eq www any

!

route-map sense permit 10

match ip address 1 110

set ip precedence critical

!

route-map sense permit 20

set ip tos 10

set ip precedence priority

Case Study: Route Tagging

用途:

用于双向重分布时标识特定Domain的路由,以防路由被重分布回起源Domain.

使用方案:

通告路由条目的边缘Router在重分布时给路由条目加上Tag标识,做为Transit Network的Domain,不需要使用和识别Tag,仅仅需要将它传递到它的外部网络即可。

路由协议相关:

Support: RIPv2,EIGRP,IS-IS,OSPF,BGP

Not Support: RIPV1,IGRP

Packets Format:

RIPv2: 支持16-bit tags 表示为十进制:0 ~ 65535

EIGRP external route TLVs: 支持32-bit tags 表示为十进制:0 ~ 4294967295

OSPF type 5 LSAs: 支持32-bit tags 表示为十进制:0 ~ 4294967295

配置实例:

router ospf 1

redistribute igrp 1 metric 10 subnets tag 1

redistribute rip metric 10 subnets route-map sense

network 10.100.200.1 0.0.0.0 area 0

!

router rip

network 10.0.0.0

!

router igrp 1

network 10.0.0.0

!

access-list 1 permit 10.1.2.3

access-list 2 permit 10.1.2.4

!

route-map sense permit 10

match ip route-source 1

set tag 2

!

route-map sense permit 20

match ip route-source 2

set tag 3

(二) Distribute-list

作用:

<1> 控制路由条目的分发,及路由的重分布。

<2> 建立一个"route firewall"

关于路由协议: www.it165.net

Distance Vector Routing Protocol: Route Filtering可以控制其通告/接收的路由条目,及重分布的路由条目。

Link-State Routing Protocol: Route Filtering只可以控制其在重分布时的路由条目。

注: LS Routing Protocol的一个基本的要求就是在一个area内所有Routers的Link State Database必须一致,所以假如Route Filtering能过滤掉LS Routing Protocol的LSA通告,就违反了LS Routing Protocol的规范。

Case Study: Filtering Specific Routes

router rip

version 2

network 192.168.75.0

distribute-list 1 in Serial1

!

ip classless

access 1 permit 0.0.0.0

Case Study: Route Filtering and Redistribution

注:

distribute-list 命令用于Link-State Routing Protocol时:

与接口联用: 只能使用in参数

与路由进程联用: 只能使用out参数

两种方案效果相同。与接口联用的方案在抑制route feedback上效果比较好;与路由进程联用的方案在抑制route feedback时,由于在过滤时,相应的路由条目已经进行了路由表,所以失效。

<1> 与接口联用

router ospf 25

redistribute rip metric 100

network 172.16.1.254 0.0.0.0 area 25

network 172.16.8.254 0.0.0.0 area 25

network 172.16.50.254 0.0.0.0 area 25

distribute-list 3 in Ethernet0/0

distribute-list 3 in Ethernet0/1

distribute-list 3 in Ethernet0/2

!

router rip

redistribute ospf 25 metric 5

passive-interface Ethernet0/0

passive-interface Ethernet0/1

passive-interface Ethernet0/2

network 192.16.0.0

distribute-list 1 in Ethernet0/3

distribute-list 1 in Ethernet2/0

distribute-ilst 1 in Ethernet2.1

!

ip classless

access-list 1 permit 172.16.128.0 0.0.127.255

access-iist 3 permit 172.16.0.0 0.0.127.255

<2> 与路由进程联用:

router ospf 25

redistribute rip metric 100

network 172.16.1.254 0.0.0.0 area 25

network 172.16.8.254 0.0.0.0 area 25

network 172.16.50.254 0.0.0.0 area 25

distribute-list 10 out rip

!

router rip

redistribute ospf 25 metric 5

passive-interface Ethernet0/3

passive-interface Ethernet2/0

passive-interface Ethernet2/1

network 172.16.0.0

distribute-list 20 out ospf 25

!

ip classless

access-list 10 permit 172.16.130.0

access-list 10 permit 172.16.145.0

access-list 10 permit 172.16.240.0

access-list 20 permit 172.16.23.0

access-list 20 permit 172.16.9.0

access-list 20 permit 172.16.75.0

(三) Prefix-list

功能:

过滤特定路由协议分发的Routes,主要用与BGP.

特性:

与ACL相比,具有相对较强的灵活性。在掩码匹配上,也比较轻易理解。

Case Study: Standard Syntax

ip prefix-list {list-name list-number} [seq number] {deny network/length permit network/length} [ge ge-length] [le le-length]

no ip prefix-list {list-name list-number} [seq number] {deny network/length permit network/length} [ge ge-length] [le le-length]

注:

<1> ip prefix-list使用最长匹配规则。

<2> 假如不指定seq number,则默认为5,且每增加一个条目自动增加5.

即假如你指定第一条目seq number为2,则下一个不指定seq number的条目的seq number自动变为7.

<3>自动增加seq number功能可以用命令:no ip prefix-list sequence-number取消。

<4> length < ge-length < le-length <= 32

<5> ip prefix-list不能与Route Maps的match ip next-hop语句联用;只以与match ip address语句联用。

Case Study: ip prefix-list description

Syntax:

ip prefix-list list-name description text

Case Study: Configuration Example

router bgp 3

no synchronization

neighbor 172.16.1.2 remote-as 3

neighbor 172.16.20.1 remote-as 1

neighbor 172.16.29.1 prefix-list 1 out

no auto-summary

!

ip prefix-list 1 seq 5 deny 192.68.10.0/24

ip prefix-list 1 seq 10 permit 0.0.0.0/32

(四) ip as-path access-list

功能:

根据BGP的AS-PATH属性过滤BGP的分发路由条目。

Case Study: Syntax

ip as-path access-list acl-number permit deny regeXP

no ip as-path access-list acl-number

注:acl-number有效值为0 ~ 500.

Case Study: Configuration Guide

<1> 过滤所有的私有AS的Routes更新

ip as-path access-list 1 deny (_64[6-9][0-9][0-9]__65[0-9][0-9][0-9]_)

ip as-path access-list 1 permit .*

<2> 应用实例

router bgp 3

no synchronization

neighbor 172.16.1.2 remote-as 3

neighbor 172.16.20.1 remote-as 1

neighbro 172.16.20.1 filter-list 1 out

no auto-summary

!

ip as-path access-lsit 1 permit ^$

(五) 以上过滤命令的执行顺序:

<1> inbound

route-map->filter-list->prefix-list,distribute-list

<2> outbound

prefix-list,distribute-list->filter-list-> route-map

prefix-list,distribute-list用于邻居在一个方向上每次只能用其中的一个

总结:

其实这些过滤命令都不是太难,要害是一个过滤的理念。

它们都是很灵活的东西,运用的好,它会有很大的作用;运用得不好,也有可能会有反作用的。

所以说,在配置这些过滤命令的时候,要仔细的斟酌。每一个过滤都要思考一下,当安放到现有的网络会有什么样的效用,这样才不至于等到安放到路由器上以后才熟悉到过滤的漏洞,才不至于引发安全隐患。

南阳宏恩科技有限公司微信ID:hnkj88 (长按复制)

网站建设、网站维护及优化、网站托管、微信平台托管、电子商务开发、微信商城开发、局域网构架;电脑及周边产品、办公耗材批发;系统集成、安防监控、门禁系统研发安装!
思科与H3C配置命令对比静态路由&OSPF

静态路由:

静态路由(static routing)是指由用户或网络管理员手工配置的路由信息。在早期网络中,网络的规模不大,路由器的数量很少,路由器也相对较小,通常采用手动的方法对每台路由器的路由表进行配置,即静态路由。这种方法适合于在规模较小、路由表也相对简单的网络中使用。它较简单,容易实现,沿用了很长一段时间。

在小规模的网络中,静态路由的优点有两点,一是手动配置,可以精确控制路由选择,改进网络的性能,二是不需要动态路由协议参与,这将会减少路由器的开销,为重要的应用保证带宽。缺点是大型和复杂的网络环境通常不宜采用静态路由。一方面,网络管理员难以全面地了解整个网络的拓扑结构;另一方面,当网络的拓扑结构和链路状态发生变化时,路由器中的静态路由信息需要大范围地调整,这一工作的难度和复杂程度非常高。当网络发生变化或网络发生故障时,不能重选路由,很可能使路由失败。

下面具体来比较思科和H3C关于静态路由的配置命令。

思科静态路由配置如下:

Router(config)#ip route 目的网段 子网掩码 下一跳/出接口

H3C 静态路由配置如下:

[Switch]ip route-static 目的网段 子网掩码 下一跳/出接口

注意:对于接口类型为非点对点的接口,不能够指定出接口,必须指定下一跳地址。

目的IP地址和掩码都为0.0.0.0的路由为默认路由。

OSPF:

OSPF(Open Shortest Path First,开放最短路径优先)是IETF 开发的基于链路状态的自治系统内部路由协议。与距离矢量协议不同,链路状态路由协议使用Dijkstra的最短路径优先算法(SPF)计算和选择路由。这类路由协议关心网络中链路或接口的状态,每个路由器将其已知的链路状态向该区域的其他路由器通告,通过这种方式,网络上的每台路由器对网络结构都会有相同的认识。随后,路由器以其为依据,使用SPF算法计算和选择路由。

OSPF具有如下特点:

适应范围广:支持各种规模的网络,最多可支持几百台路由器。

快速收敛:在网络的拓扑结构发生变化后立即发送更新报文,使这一变化在自治系统中同步。

无自环:由于OSPF根据收集到的链路状态用最短路径树算法计算路由,从算法本身保证了不会生成自环路由。

区域划分:允许自治系统的网络被划分成区域来管理。路由器链路状态数据库的减小降低了内存的消耗和CPU的负担;区域间传送路由信息的减少降低了网络带宽的占用。

等价路由:支持到同一目的地址的多条等价路由。

路由分级:使用4类不同的路由,按优先顺序来说分别是:区域内路由、区域间路由、第一类外部路由、第二类外部路由。

支持验证:支持基于接口的报文验证,以保证报文交互和路由计算的安全性。

组播发送:在某些类型的链路上以组播地址发送协议报文,减少对其他设备的干扰。

下面具体来比较思科和H3C关于静态路由的配置命令。

思科OSPF配置如下:

router(config)#router ospf 进程号 //进入路由协议配置模式

router(config-router)#network 接口网段 反掩码 area 区域号 //宣告网段

show ip ospf neighbor //查看ospf邻居状态

H3C OSPF配置如下:

[Router] ospf 1 //启动OSPF进程

[Router-ospf-1] area 0 //配置OSPF区域

[Router-ospf-1-area-0.0.0.0] network 接口网段 反掩码 //在指定的接口上启动OSPF

[Router] display ospf peer //显示OSPF邻居信息


思科路由命令大全(一)

Cisco 路由器常用命令

1 Exec commands:

2 #show ?

3 #config ?

4 Configure commads:

5 (config)#ip

如感兴趣可点击原文链接查看网页全文内容,建议在wifi环境下使用。


Cisco路由器配置入门知识(基础)

Cisco路由配置基础

刚刚接触cisco路由配置,下面是学习的笔记,感觉命令还是多敲才能熟悉

一、 所处状态各类

router>

用户处于用户命令状态,可以查看网络和主机

router#

用户处于特权模式,可以查看状态,还可以看到和更改路由器的设置内容

router(config)#

全局配置状态,可以设置路由的全局参数

router(config-if)#;router(config-line)#;router(config-router)#.....

处于局部配置状态,可以设置路由的局部参数

二、配置端口ip

命令

en

config t //全局模式

interface f0/0

ip address 192.168.1.1 255.255.255.0 //设置端口ip

no shu //生效

exit

interface f0/1

ip address 192.168.10.1 255.255.255.0

no shu

exit

end

disable

三、配置静态路由

命令

en

config t //全局模式

ip route 192.168.100.0 255.255.255.0 192.168.10.2 //到192.168.100.0/24通过192.168.10.2接口

end

show ip route //可以看到前面标明S,即为静态路由

四、配置动态路由(RIP)

命令

en

config t //全局模式

no route rip //禁止rip协议

route rip

network 192.168.1.0 //network参数为路由的两个端口对应的网络地址

network 192.168.10.0

exit

end

disable

五、配置DHCP

命令

en

config t //全局模式

ip dhcp excluded-address 192.168.1.1 //需要排除的ip地址

ip dhcp pool gr-dhcp-pool //ip地址池名

default-server 192.168.1.1 //指定dhcp服务器

network 192.168.1.0 255.255.255.0 //配置网络

dns-server 61.177.7.1 //配置dns服务器

exit

end

disable

可以通过 ip helper-address指定 DHCP中继代理

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

ip helper-address 192.168.10.2 \\配置DHCP中继代理,DHCP

六、配置NAT

命令

en

config t //全局模式

interface f0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside //内部端口

no shu

exit

interface f0/1

ip address 192.168.10.1 255.255.255.0

ip nat outside //外部端口

no shu

exit

access-list 1 permit any //设置一个可访问列表

ip nat pool gr-nat-pool 192.168.10.3 192.168.10.254 netmask 255.255.255.0 //设置分配池

ip nat inside resource list 1 pool gr-nat-pool overload

show ip nat traslations

clear ip nat traslation *

七、其它

sh running-config //显示当前运行配置

sh startup-config //显示开机配置

sh ip route //显示路由

sh nat traslations //显示nat当前情况

微思网址:http://www.xmws.cn

腾讯微博:http://t.qq.com/xmwisdom

新浪微博:http://weibo.com/xmwisdom
华为华为路由器交换机配置命令大全

一、计算机命令

PCAlogin:root;使用root用户

password:linux;口令是linux

#shutdown-hnow;关机

#init0;关机

#logout;用户注销

#login;用户登录

#ifconfig;显示IP地址

#ifconfigeth0netmask;设置IP地址

#ifconfigeht0netmaskdown;禁用IP地址

#routeadd0.0.0.0gw;设置网关

#routedel0.0.0.0gw;删除网关

#routeadddefaultgw;设置网关

#routedeldefaultgw;删除网关

#route;显示网关

#ping;发ECHO包

#telnet;远程登录

二、华为路由器交换机配置命令:交换机命令

[Quidway]discur;显示当前配置

[Quidway]displaycurrent-configuration;显示当前配置

[Quidway]displayinterfaces;显示接口信息

[Quidway]displayvlanall;显示路由信息

[Quidway]displayversion;显示版本信息

[Quidway]superpassword;修改特权用户密码

[Quidway]sysname;交换机命名

[Quidway]interfaceethernet0/1;进入接口视图

[Quidway]interfacevlanx;进入接口视图

[Quidway-Vlan-interfacex]ipaddress10.65.1.1255.255.0.0;配置VLAN的IP地址

[Quidway]iproute-static0.0.0.00.0.0.010.65.1.2;静态路由=网关

[Quidway]rip;三层交换支持

[Quidway]local-userftp

[Quidway]user-interfacevty04;进入虚拟终端

[S3026-ui-vty0-4]authentication-modepassword;设置口令模式

[S3026-ui-vty0-4]setauthentication-modepasswordsimple222;设置口令

[S3026-ui-vty0-4]userprivilegelevel3;用户级别

[Quidway]interfaceethernet0/1;进入端口模式

[Quidway]inte0/1;进入端口模式

[Quidway-Ethernet0/1]duplex{half|full|auto};配置端口工作状态

[Quidway-Ethernet0/1]speed{10|100|auto};配置端口工作速率

[Quidway-Ethernet0/1]flow-control;配置端口流控

[Quidway-Ethernet0/1]mdi{across|auto|normal};配置端口平接扭接

[Quidway-Ethernet0/1]portlink-type{trunk|access|hybrid};设置端口工作模式

[Quidway-Ethernet0/1]portaccessvlan3;当前端口加入到VLAN

[Quidway-Ethernet0/2]porttrunkpermitvlan{ID|All};设trunk允许的VLAN

[Quidway-Ethernet0/3]porttrunkpvidvlan3;设置trunk端口的PVID

[Quidway-Ethernet0/1]undoshutdown;激活端口

[Quidway-Ethernet0/1]shutdown;关闭端口

[Quidway-Ethernet0/1]quit;返回

[Quidway]vlan3;创建VLAN

[Quidway-vlan3]portethernet0/1;在VLAN中增加端口

[Quidway-vlan3]porte0/1;简写方式

[Quidway-vlan3]portethernet0/1toethernet0/4;在VLAN中增加端口

[Quidway-vlan3]porte0/1toe0/4;简写方式

[Quidway]monitor-port;指定镜像端口

[Quidway]portmirror;指定被镜像端口

[Quidway]portmirrorint_listobserving-portint_typeint_num;指定镜像和被镜像

[Quidway]descriptionstring;指定VLAN描述字符

[Quidway]description;删除VLAN描述字符

[Quidway]displayvlan[vlan_id];查看VLAN设置

[Quidway]stp{enable|disable};设置生成树,默认关闭

[Quidway]stppriority4096;设置交换机的优先级

[Quidway]stproot{primary|secondary};设置为根或根的备份

[Quidway-Ethernet0/1]stpcost200;设置交换机端口的花费

[Quidway]link-aggregatione0/1toe0/4ingress|both;端口的聚合

[Quidway]undolink-aggregatione0/1|all;始端口为通道号

[SwitchA-vlanx]isolate-user-vlanenable;设置主vlan

[SwitchA]isolate-user-vlansecondary;设置主vlan包括的子vlan

[Quidway-Ethernet0/2]porthybridpvidvlan;设置vlan的pvid

[Quidway-Ethernet0/2]porthybridpvid;删除vlan的pvid

[Quidway-Ethernet0/2]porthybridvlanvlan_id_listuntagged;设置无标识的vlan

如果包的vlanid与PVId一致,则去掉vlan信息.默认PVID=1。

所以设置PVID为所属vlanid,设置可以互通的vlan为untagged.

三、华为路由器交换机配置命令:路由器命令

[Quidway]displayversion;显示版本信息

[Quidway]displaycurrent-configuration;显示当前配置

[Quidway]displayinterfaces;显示接口信息

[Quidway]displayiproute;显示路由信息

[Quidway]sysnameaabbcc;更改主机名

[Quidway]superpasswrod123456;设置口令

[Quidway]interfaceserial0;进入接口

[Quidway-serial0]ipaddress;配置端口IP地址

[Quidway-serial0]undoshutdown;激活端口

[Quidway]link-protocolhdlc;绑定hdlc协议

[Quidway]user-interfacevty04

[Quidway-ui-vty0-4]authentication-modepassword

[Quidway-ui-vty0-4]setauthentication-modepasswordsimple222

[Quidway-ui-vty0-4]userprivilegelevel3

[Quidway-ui-vty0-4]quit

[Quidway]debugginghdlcallserial0;显示所有信息

[Quidway]debugginghdlceventserial0;调试事件信息

[Quidway]debugginghdlcpacketserial0;显示包的信息

四、华为路由器交换机配置命令:静态路由:

[Quidway]iproute-static{interfacenumber|nexthop}[value][reject|blackhole]

例如:[Quidway]iproute-static129.1.0.01610.0.0.2

[Quidway]iproute-static129.1.0.0255.255.0.010.0.0.2

[Quidway]iproute-static129.1.0.016Serial2

[Quidway]iproute-static0.0.0.00.0.0.010.0.0.2

五、华为路由器交换机配置命令:动态路由:

[Quidway]rip;设置动态路由

[Quidway]ripwork;设置工作允许

[Quidway]ripinput;设置入口允许

[Quidway]ripoutput;设置出口允许

[Quidway-rip]network1.0.0.0;设置交换路由网络

[Quidway-rip]networkall;设置与所有网络交换

[Quidway-rip]peerip-address;

[Quidway-rip]summary;路由聚合

[Quidway]ripversion1;设置工作在版本1

[Quidway]ripversion2multicast;设版本2,多播方式

[Quidway-Ethernet0]ripsplit-horizon;水平分隔

[Quidway]routeridA.B.C.D;配置路由器的ID

[Quidway]ospfenable;启动OSPF协议

[Quidway-ospf]import-routedirect;引入直联路由

[Quidway-Serial0]ospfenablearea;配置OSPF区域

六、华为路由器交换机配置命令:标准访问列表命令格式如下:

acl[match-orderconfig|auto];默认前者顺序匹配。

rule[normal|special]{permit|deny}[sourcesource-addrsource-wildcard|any]

例:[Quidway]acl10

[Quidway-acl-10]rulenormalpermitsource10.0.0.00.0.0.255

[Quidway-acl-10]rulenormaldenysourceany

七、华为路由器交换机配置命令:扩展访问控制列表配置命令

配置TCP/UDP协议的扩展访问列表:

rule{normal|special}{permit|deny}{tcp|udp}source{|any}destination|any}

[operate]

配置ICMP协议的扩展访问列表:

rule{normal|special}{permit|deny}icmpsource{|any]destination{|any]

[icmp-code][logging]

八、华为路由器交换机配置命令:扩展访问控制列表操作符的含义

equalportnumber;等于

greater-thanportnumber;大于

less-thanportnumber;小于

not-equalportnumber;不等

rangeportnumber1portnumber2;区间

九、华为路由器交换机配置命令:扩展访问控制列表举例

[Quidway]acl101

[Quidway-acl-101]ruledenysouceanydestinationany

[Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho

[Quidway-acl-101]rulepermiticmpsourceanydestinationanyicmp-typeecho-reply

[Quidway]acl102

[Quidway-acl-102]rulepermitipsource10.0.0.10.0.0.0destination202.0.0.10.0.0.0

[Quidway-acl-102]ruledenyipsourceanydestinationany

[Quidway]acl103

[Quidway-acl-103]rulepermittcpsourceanydestination10.0.0.10.0.0.0destination-portequalftp

[Quidway-acl-103]rulepermittcpsourceanydestination10.0.0.20.0.0.0destination-portequalwww

[Quidway]firewallenable

[Quidway]firewalldefaultpermit|deny

[Quidway]inte0

[Quidway-Ethernet0]firewallpacket-filter101inbound|outbound

十、华为路由器交换机配置命令:地址转换配置举例

[Quidway]firewallenable

[Quidway]firewalldefaultpermit

[Quidway]acl101;内部指定主机可以进入e0

[Quidway-acl-101]ruledenyipsourceanydestinationany

[Quidway-acl-101]rulepermitipsource129.38.1.10destinationany

[Quidway-acl-101]rulepermitipsource129.38.1.20destinationany

[Quidway-acl-101]rulepermitipsource129.38.1.30destinationany

[Quidway-acl-101]rulepermitipsource129.38.1.40destinationany

[Quidway-acl-101]quit

[Quidway]inte0

[Quidway-Ethernet0]firewallpacket-filter101inbound

[Quidway]acl102;外部特定主机和大于1024端口的数据包允许进入S0

[Quidway-acl-102]ruledenyipsourceanydestinationany

[Quidway-acl-102]rulepermittcpsource202.39.2.30destination202.38.160.10

[Quidway-acl-102]rulepermittcpsourceanydestination202.38.160.10destination-portgreat-than

1024

[Quidway-acl-102]quit

[Quidway]ints0

[Quidway-Serial0]firewallpacket-filter102inbound;设202.38.160.1是路由器出口IP。

[Quidway-Serial0]natoutbound101interface;是Easyip,将acl101允许的IP从本接口出时变换源地址。

十一、华为路由器交换机配置命令:内部服务器地址转换配置命令(静态nat):

natserverglobal[port]insideport[protocol];global_port不写时使用inside_port

[Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.1ftptcp

[Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.2telnettcp

[Quidway-Serial0]natserverglobal202.38.160.1inside129.38.1.3wwwtcp

设有公网IP:202.38.160.101~202.38.160.103可以使用。;对外访问(原例题)

[Quidway]nataddress-group202.38.160.101202.38.160.103pool1;建立地址池

[Quidway]acl1

[Quidway-acl-1]rulepermitsource10.110.10.00.0.0.255;指定允许的内部网络

[Quidway-acl-1]ruledenysourceany

[Quidway-acl-1]intserial0

[Quidway-Serial0]natoutbound1address-grouppool1;在s0口从地址池取出IP对外访问

[Quidway-Serial0]natserverglobal202.38.160.101inside10.110.10.1ftptcp

[Quidway-Serial0]natserverglobal202.38.160.102inside10.110.10.2wwwtcp

[Quidway-Serial0]natserverglobal202.38.160.1028080inside10.110.10.3wwwtcp

[Quidway-Serial0]natserverglobal202.38.160.103inside10.110.10.4smtpudp

华为路由器交换机配置命令:PPP设置:[Quidway-s0]link-protocolppp;默认的协议

十二、华为路由器交换机配置命令:PPP验证:

主验方:pap|chap

[Quidway]local-userq2password{simple|cipher}hello;路由器1

[Quidway]interfaceserial0

[Quidway-serial0]pppauthentication-mode{pap|chap}

[Quidway-serial0]pppchapuserq1;pap时,没有此句

十三、华为路由交换机配置命令:pap被验方:

[Quidway]interfaceserial0;路由器2

[Quidway-serial0]ppppaplocal-userq2password{simple|cipher}hello

十四、华为路由器交换机配置命令:chap被验方:

[Quidway]interfaceserial0;路由器2

[Quidway-serial0]pppchapuserq2;自己路由器名

[Quidway-serial0]local-userq1password{simple|cipher}hello;对方路由器名

帧中继frame-relay(二分册6-61)

[q1]frswitching

[q1]ints1

[q1-Serial1]ipaddress192.168.34.51255.255.255.0

[q1-Serial1]link-protocolfr;封装帧中继协议

[q1-Serial1]frinterface-typedce

[q1-Serial1]frdlci100

[q1-Serial1]frinarp

[q1-Serial1]frmapip192.168.34.52dlci100

[q2]ints1

[q2-Serial1]ipaddress192.168.34.52255.255.255.0

[q2-Serial1]link-protocolfr

[q2-Serial1]frinterface-typedte

[q2-Serial1]frdlci100

[q2-Serial1]frinarp

[q2-Serial1]frmapip192.168.34.51dlci100

十五、华为路由器交换机配置命令:帧中继监测

[q1]displayfrlmi-info[]interfacetypenumber]

[q1]displayfrmap

[q1]displayfrpvc-info[serialinterface-number][dlcidlci-number]

[q1]displayfrdlci-switch

[q1]displayfrinterface

[q1]resetfrinarp-info

[q1]debuggingfrall[interfacetypenumber]

[q1]debuggingfrarp[interfacetypenumber]

[q1]debuggingfrevent[interfacetypenumber]

[q1]debuggingfrlmi[interfacetypenumber]

十六、华为路由器交换机配置命令:启动ftp服务:

[Quidway]local-userftppassword{simple|cipher}aaaservice-typeftp

[Quidway]ftpserverenable

清默试听热线:

0551-65436206

0551-65436208

15056089769

了解我们:http://www.qmcisco.com

http://www.qingm.net

分享到您的社交平台:

admin 推荐阅读:

发表评论:

您必须 [ 登录 ] 才能发表留言!